Wednesday, 22 May 2013

Frame Relay End to End Keepalive

LMI (Local Management interface) salah satu fungsinya adalah sebagai keepalive, namun terbatas hanya pada lokal link antara router dan FR switch. agar bisa mengetahui status remote end / ujung jauh kita bisa menggunakan Frame Relay end-to-end keepalive (FREEK). dengan begitu status dari DTE ujung bisa diketahui statusnya. apabila remote end down maka Router dapat dengan cepat mengambil keputusan untuk menggunakan link cadangan / backup (failover).

R2(config)#frame-relay switching
R2(config)#interface s1/0
R2(config-if)#encapsulation frame-relay
R2(config-if)#frame-relay intf-type dce
R2(config-if)#frame-relay lmi-type cisco
R2(config-if)#frame-relay route 102 interface s1/1 201
R2(config-if)#no shut
R2(config-if)#interface s1/1
R2(config-if)#encapsulation frame-relay
R2(config-if)#frame-relay intf-type dce
R2(config-if)#frame-relay lmi-type cisco
R2(config-if)#frame-relay route 201 interface s1/0 102
R2(config-if)#no shut
R1(config)#interface s1/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#no shut
R1(config-if)#interface s1/0.1 point
R1(config-subif)#ip add 12.12.12.1 255.255.255.0
R1(config-subif)#frame-relay interface-dlci 102
R1(config-fr-dlci)#class freek
R1(config-fr-dlci)#exit
R1(config-subif)#backup interface s1/1
R1(config)#interface s1/1
R1(config-if)#ip add 21.21.21.1 255.255.255.0
R1(config-if)#no shut
R1(config)#router eigrp 10
R1(config-router)#network 0.0.0.0
R1(config-router)#exit
R1(config)#map-class frame-relay freek
R1(config-map-class)#frame-relay end-to-end keepalive mode bidirectional
R3(config)#interface s1/0
R3(config-if)#encapsulation frame-relay
R3(config-if)#no shutdown
R3(config-if)#interface s1/0.1 multipoint
R3(config-subif)#ip add 12.12.12.2 255.255.255.0
R3(config-subif)#frame-relay interface-dlci 201
R3(config-fr-dlci)#class freek
%Creating new map-class.
R3(config-fr-dlci)#exit
R3(config-subif)#backup interface s1/1
R3(config)#interface s1/1
R3(config-if)#ip add 21.21.21.2 255.255.255.0
R3(config-if)#no shut
R3(config-if)#router eigrp 10
R3(config-router)#network 0.0.0.0
R3(config-router)#exit
R3(config-map-class)#frame-relay end-to-end keepalive mode bidirectional
R1#show frame-relay end-to-end keepalive
End-to-end Keepalive Statistics for Interface Serial1/0 (Frame Relay DTE)
DLCI = 102, DLCI USAGE = LOCAL, VC STATUS = ACTIVE (EEK UP)

R3(config-map-class)#do show frame-relay end-to-end keepalive
End-to-end Keepalive Statistics for Interface Serial1/0 (Frame Relay DTE)
DLCI = 201, DLCI USAGE = LOCAL, VC STATUS = ACTIVE (EEK UP) 
apabila S1/0 R3 jatuh,
R1#show frame-relay end-to-end keepalive
End-to-end Keepalive Statistics for Interface Serial1/0 (Frame Relay DTE)
DLCI = 102, DLCI USAGE = LOCAL, VC STATUS = ACTIVE (EEK DOWN)
 otomatis link backupnya akan digunakan.