Kita akan mempelajari Summary Address pada Routing RIP, Peringkasan routing tabel berpengaruh terhadap penggunaan memory dan processor Router sehingga kinerja router akan lebih ringan.
Topologi yang digunakan :
Konfigurasi R1
R1(config)#int f0/0
R1(config-if)#ip add 12.12.12.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#int lo0
R1(config-if)#ip add 1.1.1.1 255.255.
R1(config-if)#ip add 12.12.12.1 255.255.255.255.255
selanjutnya kita buat ip loopback yang banyak untuk pengetesan
R1(config-if)#interface lo1
R1(config-if)#ip add 10.0.0.1 255.255.255.255
R1(config-if)#interface lo2
R1(config-if)#ip add 10.0.1.1 255.255.255.255
R1(config-if)#interface lo3
R1(config-if)#ip add 10.0.2.1 255.255.255.255
R1(config-if)#interface lo4
R1(config-if)#ip add 10.0.4.1 255.255.255.255
R1(config-if)#interface lo5
R1(config-if)#ip add 10.0.5.1 255.255.255.255
R1(config-if)#int lo6
R1(config-if)#ip add 10.0.6.1 255.255.255.255
R1(config-if)#int lo7
R1(config-if)#ip add 10.0.7.1 255.255.255.255
R1(config-if)#int lo8
R1(config-if)#ip add 10.0.8.1 255.255.255.255
R1(config-if)#int lo9
R1(config-if)#ip add 10.0.9.1 255.255.255.255
R1(config-if)#int lo10
R1(config-if)#ip add 10.0.10.1 255.255.255.255
R1(config-if)#int lo20
R1(config-if)#ip add 20.0.0.1 255.255.255.255
R1(config-if)#int lo21
R1(config-if)#ip add 20.0.1.1 255.255.255.255
R1(config-if)#int lo22
R1(config-if)#ip add 20.0.2.1 255.255.255.255
R1(config-if)#int lo23
R1(config-if)#int lo30
R1(config-if)#ip add 30.0.0.1 255.255.255.255
R1(config-if)#int lo31
R1(config-if)#ip add 30.0.1.1 255.255.255.255
R1(config-if)#int lo32
R1(config-if)#ip add 30.0.2.1 255.255.255.255
Aktifkan Routing RIP
R1(config-if)#router rip
R1(config-router)#version 2
R1(config-router)#network 1.0.0.0
R1(config-router)#network 12.0.0.0
R1(config-router)#network 10.0.0.0
R1(config-router)#network 20.0.0.0
R1(config-router)#network 30.0.0.0
R1(config-router)#no auto-summary
Konfigurasi R2
R2(config)#int f0/0R2(config-if)#ip add 12.12.12.2 255.255.255.0R2(config-if)#no shutR2(config-if)#int f0/1R2(config-if)#ip add 23.23.23.2 255.255.255.0R2(config-if)#no shutR2(config-if)#int lo0R2(config-if)#ip add 2.2.2.2 255.255.255.255R2(config-if)#router ripR2(config-router)#version 2R2(config-router)#network 12.0.0.0R2(config-router)#network 2.0.0.0R2(config-router)#network 23.0.0.0R2(config-router)#no auto-summary
Konfigurasi R3
R3(config)#interface f0/0R3(config-if)#ip add 23.23.23.3 255.255.255.0R3(config-if)#no shutR3(config-if)#int loR3(config-if)#ip add 3.3.3.3 255.255.255.255R3(config-if)#router ripR3(config-router)#version 2R3(config-router)#network 23.0.0.0R3(config-router)#network 3.0.0.0R3(config-router)#no auto-summary
sekarang kita coba lihat routing tabel
pada R3
R3(config-router)#do sh ip routeGateway of last resort is not set1.0.0.0/32 is subnetted, 1 subnetsR 1.1.1.1 [120/2] via 23.23.23.2, 00:00:10, FastEthernet0/02.0.0.0/32 is subnetted, 1 subnetsR 2.2.2.2 [120/1] via 23.23.23.2, 00:00:10, FastEthernet0/03.0.0.0/32 is subnetted, 1 subnetsC 3.3.3.3 is directly connected, Loopback020.0.0.0/32 is subnetted, 3 subnetsR 20.0.1.1 [120/2] via 23.23.23.2, 00:00:10, FastEthernet0/0R 20.0.0.1 [120/2] via 23.23.23.2, 00:00:10, FastEthernet0/0R 20.0.2.1 [120/2] via 23.23.23.2, 00:00:10, FastEthernet0/023.0.0.0/24 is subnetted, 1 subnetsC 23.23.23.0 is directly connected, FastEthernet0/010.0.0.0/32 is subnetted, 10 subnetsR 10.0.10.1 [120/2] via 23.23.23.2, 00:00:12, FastEthernet0/0R 10.0.9.1 [120/2] via 23.23.23.2, 00:00:13, FastEthernet0/0R 10.0.8.1 [120/2] via 23.23.23.2, 00:00:13, FastEthernet0/0R 10.0.2.1 [120/2] via 23.23.23.2, 00:00:13, FastEthernet0/0R 10.0.1.1 [120/2] via 23.23.23.2, 00:00:13, FastEthernet0/0R 10.0.0.1 [120/2] via 23.23.23.2, 00:00:13, FastEthernet0/0R 10.0.7.1 [120/2] via 23.23.23.2, 00:00:13, FastEthernet0/0R 10.0.6.1 [120/2] via 23.23.23.2, 00:00:13, FastEthernet0/0R 10.0.5.1 [120/2] via 23.23.23.2, 00:00:13, FastEthernet0/0R 10.0.4.1 [120/2] via 23.23.23.2, 00:00:13, FastEthernet0/012.0.0.0/24 is subnetted, 1 subnetsR 12.12.12.0 [120/1] via 23.23.23.2, 00:00:13, FastEthernet0/030.0.0.0/32 is subnetted, 3 subnetsR 30.0.2.1 [120/2] via 23.23.23.2, 00:00:13, FastEthernet0/0R 30.0.1.1 [120/2] via 23.23.23.2, 00:00:13, FastEthernet0/0R 30.0.0.1 [120/2] via 23.23.23.2, 00:00:13, FastEthernet0/0
Terlihat banyak sekali network yang
ada, sekarang kita coba ringkas untuk meringankan kerja router
Konfigurasi pada R1
R1(config)#int f0/0R1(config-if)#ip summary-address rip 10.0.0.0 255.0.0.0R1(config-if)#ip summary-address rip 20.0.0.0 255.0.0.0R1(config-if)#ip summary-address rip 30.0.0.0 255.0.0.0
sekarang coba cek lagi routing tabel
pada R3
R3#clear ip route *R3#show ip routeGateway of last resort is not set1.0.0.0/32 is subnetted, 1 subnetsR 1.1.1.1 [120/2] via 23.23.23.2, 00:00:03, FastEthernet0/02.0.0.0/32 is subnetted, 1 subnetsR 2.2.2.2 [120/1] via 23.23.23.2, 00:00:03, FastEthernet0/03.0.0.0/32 is subnetted, 1 subnetsC 3.3.3.3 is directly connected, Loopback0R 20.0.0.0/8 [120/2] via 23.23.23.2, 00:00:03, FastEthernet0/023.0.0.0/24 is subnetted, 1 subnetsC 23.23.23.0 is directly connected, FastEthernet0/0R 10.0.0.0/8 [120/2] via 23.23.23.2, 00:00:03, FastEthernet0/012.0.0.0/24 is subnetted, 1 subnetsR 12.12.12.0 [120/1] via 23.23.23.2, 00:00:03, FastEthernet0/0R 30.0.0.0/8 [120/2] via 23.23.23.2, 00:00:03, FastEthernet0/0