R1, R2, R3 ketiganya merupakan router RIP. skenarionya disini R1 akan update unicast ke R2 dan R2 update unicast ke R3.
R1(config)#interface f0/0
R1(config-if)#ip add 12.12.12.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#router rip
R1(config-router)#v 2
R1(config-router)#network 0.0.0.0
harus dikonfig manual neighbornya
R1(config-router)#neighbor 12.12.12.2
R2(config)#interface f0/0
R2(config-if)#ip add 12.12.12.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#router rip
R2(config-router)#v 2
R2(config-router)#network 0.0.0.0
R2(config-router)#neighbor 12.12.12.1
dilihat pada debug ip rip, update yang dikrimkan malah masih tetap menggunakan multicast walaupun unicastnya sudah bisa. untuk itu perlu dikonfigurasikan passive-interface pada rip configuration
R1#debug ip rip
*Mar 1 00:08:41.367: %SYS-5-CONFIG_I: Configured from console by console
RIP protocol debugging is on
R1#
*Mar 1 00:08:59.427: RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0 (12.12.12.1)
*Mar 1 00:08:59.427: RIP: build update entries - suppressing null update
*Mar 1 00:08:59.427: RIP: sending v2 update to 12.12.12.2 via FastEthernet0/0 (12.12.12.1)
passive interface pada rip digunakan agar interface tidak mengirimkan update, tetapi masih bisa menerima update.Selanjutnya R2 ke R4 dikonfig untuk update secara unicast tetapi melalui Router non-RIP.
R1(config-router)#passive-interface f0/0
R2(config-router)#passive-interface f0/0
R1(config-router)#
*Mar 1 00:13:37.767: RIP: sending v2 update to 12.12.12.2 via FastEthernet0/0 (12.12.12.1)
*Mar 1 00:13:37.767: RIP: build update entries - suppressing null update
R2(config)#interface f0/1
R2(config-if)#ip add 23.23.23.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#router rip
tambahkan ip unicast R4 dengan command neighbor, kemudian buat statik routing agar packet bisa tersampaikan dari R2 Ke R4.
R2(config-router)#neighbor 34.34.34.4
R2(config-router)#passive-interface f0/1
R2(config-router)#ex
R2(config)#ip route 34.34.34.0 255.255.255.0 f0/1
R4(config)#interface f0/0
R4(config-if)#ip add 34.34.34.4 255.255.255.0
R4(config-if)#no shut
R4(config-if)#ip route 23.23.23.0 255.255.255.0 f0/0
R4(config)#router rip
R4(config-router)#v 2
R4(config-router)#network 0.0.0.0
R4(config-router)#neighbor 23.23.23.2
R4(config-router)#passive-interface f0/0
Router R4 sudah mengirimkan update secara unicast, tapi route dari R2 belum akan ada di routing tabel milik R4 karena debug dibawah ini menunjukan bahwa R4 menolak update dari R2.
hal ini terjadi karena RIP tidak akan pernah menerima update dari source yang tidak memiliki subnet yang sama. untuk mengatasi itu kita disable validasi update sourcenya.
R4#debug ip rip
RIP protocol debugging is on
R4#
*Mar 1 00:24:24.159: RIP: sending v2 update to 23.23.23.2 via FastEthernet0/0 (34.34.34.4)
*Mar 1 00:24:24.159: RIP: build update entries - suppressing null update
*Mar 1 00:24:48.211: RIP: ignored v2 update from bad source 23.23.23.2 on FastEthernet0/0
R2(config-router)#no validate-update-sourcesekarang pada routing tabel R4 akan masuk route yang bersumber dari R2
R4(config-router)#no validate-update-source
R4(config-router)#do show ip route
34.0.0.0/24 is subnetted, 1 subnets
C 34.34.34.0 is directly connected, FastEthernet0/0
23.0.0.0/24 is subnetted, 1 subnets
S 23.23.23.0 is directly connected, FastEthernet0/0
R 12.0.0.0/8 [120/1] via 23.23.23.2, 00:00:01